Overview

The XPProgress collection mimics the new and appealing Windows XP ProgressBar and Working controls. As with all the XPSuite controls, you don't have to have Windows XP to have this appearance.

The XPProgress control set contains two separate controls. First the ProgressBar provides a 0 to 100 percent progress status. Second the ProgressWait moves in various directions to show that the system is working.

Both controls can sized to any size, the gradient colors of the individual bars can set as desired, and the direction of fill (ProgressBar) or movement (ProgressWait) can be set as desired. The ProgressBar has an additional feature to alert users when it is full, at 100 percent. This is achieved by setting an additional set of gradient colors to be applied to the control upon 100 fill. The ProgressWait's speed can be adjusted, as well as the direction of travel (left to right, right to left, or both).

Total Process Control 2000 is a registered trademark of CIA, The Company, Inc.
Copyright 1999-2002. All rights reserved.


Getting Started

After running the setup routine to install ciaXPProgress.ocx you need to add the ocx file to the project. This can be performed in Visual Basic as follows:

1. From the Project menu item, click "Components".
2. Scroll down until you find "CIA XP Progress Bar and Wait Controls"
3. Check this item, and click "OK".
4. The ocx will be displayed in the toolbox.


Properties (ProgressBar Object)

BackColor
Direction
GradientFrom
GradientTo
HighLightColorFrom
HighLightColorTo
HighLightOnFull
Value


Methods (ProgressBar Object)

This control has no methods


Events (ProgressBar Object)

This control has no events


Properties (ProgressWait Object)

BackColor
Direction
GradientFrom
GradientTo
Speed


Methods (ProgressWait Object)

progStart
progStop


Events (ProgressWait Object)

This control has no events


Getting Technical Support

Contacting technical support (for registered users)

Support Email: support@ciatheco.com
Support Page: http://www.ciatheco.com/Support.htm
Website: http://www.ciatheco.com


Registering

Registering is easy. Simply go to CIA's register site. Fill the required fields and you are now eligible for full technical support.

Note, that registering can only be performed if you have a valid licence key, which you will receive after purchasing the control.


BackColor

Progress Controls

Property BackColor() as OLE_Color

Applies To:
ProgressBar Control
ProgressWait Control

Description:
Returns or Sets the back ground color of the control.

Default value is vbWhite

Syntax:
<value> = object.BackColor
object.BackColor = <value>
where: <value> is a long value

Example:
Progress1.BackColor = vbWhite


Direction

Progress Controls

Property Direction() As Integer

Applies To:
ProgressBar Control
ProgressWait Control

Description:
For the ProgressBar, this property Returns or Sets the fill direction. The available values for direction are as follows:
0 - Left to Right
1 - Right to Left

For the ProgressWait control, this property Returns or Sets the direction the wait indicator moves. The available values are as follows:
0 - Left to Right
1 - Right to Left
2 - Both (in this mode, the wait indicator moves first from left to right, disappearing, in the right edge, then reappears from the right side, moving to the left.

Syntax:
<value> = object.Diretion
object.Diretion = <value>
where: <value> is an Integer value

Default Value is 0 - Left to Right

Example:
ProgressBar1.Diretion = 1


GradientFrom

Progress Controls

Property GradientFrom() as OLE_Color

Applies To:
ProgressBar Control
ProgressWait Control

Description:
Returns or Sets the start color of the gradient fill of the individual bars. Gradient fills from the bottom to top.

Syntax:
<value> = object.GradientFrom
object.GradientFrom = <value>
where: <value> is a Long value

Default Value is vbGreen

Example:
ProgressBar1.GradientFrom = vbGreen


GradientTo

Progress Controls

Property GradientTo() as OLE_Color

Applies To:
ProgressBar Control
ProgressWait Control

Description:
Returns or Sets the end color of the gradient fill of the individual bars. Gradient fills from the bottom to the top.

Syntax:
<value> = object.GradientTo
object.GradientTo = <value>
where: <value> is a Long value

Default Value is vbWhite

Example:
ProgressBar1.GradientTo = vbWhite


HighLightColorFrom

Progress Controls

Property HighLightColorFrom() as OLE_Color

Applies To:
ProgressBar Control

Description:
Returns or Sets the start color of the gradient fill of the individual bars. Gradient fills from the bottom to top.

Syntax:
<value> = object.HighLightColorFrom
object.HighLightColorFrom = <value>
where: <value> is a long value

Default Value is vbWhite

Example:
ProgressBar1.HighLightColorFrom = vbWhite


HighLightColorTo

Progress Controls

Property HighLightColorTo() as OLE_Color

Applies To:
ProgressBar Control

Description:
Returns or Sets the end color of the gradient fill of the individual bars. Gradient fills from the bottom to the top.

Syntax:
<value> = object.HighLightColorTo
object.HighLightColorTo = <value>
where: <value> is a long value

Default Value is vbRed

Example:
ProgressBar1.HighLightColorTo = vbRed


HighLightOnFull

Progress Controls

HighLightOnFull As Boolean

Applies To:
ProgressBar Control

Description:
Returns or Sets whether to fill the entire background with a gradient style fill upon the progress bar value reaching 100 percent.

Syntax:
<value> = object.HighLightOnFull
object.HighLightOnFull = <value>
where: <value> is a Boolean value

Default Value is True

Example:
ProgressBar1.HighLightOnFull = True


progStart Method

Applies To:
ProgressWait Control

Description:
Starts motion in the direction specified by the Direction property.

Syntax:
object.Start

Example:
ProgressWait1.Start


progStop Method

Applies To:
ProgressWait Control

Description:
Stops motion, and clears the visible display of the progress wait indicator.

Syntax:
object.progStop

Example:
ProgressWait1.progStop


Speed

Progress Controls

Property Speed() as Integer

Applies To:
ProgressWait Control

Description:
Returns or Sets the motion speed. Valid range is 1 to 10, where 1 is the slowest speed, and 10 is the fastest speed.

Syntax:
<value> = object.Speed
object.Speed = <value>
where: <value> is an Integer value

Default Value is 3

Example:
ProgressWait1.Speed = 3


Value

Progress Controls

Property Value() as Integer

Applies To:
ProgressBar Control

Description:
Returns or Sets the percent filled value. Valid range is 0 to 100.

Syntax:
<value> = object.Value
object.Value = <value>
where: <value> is an Integer value

Default Value is 0

Example:
ProgressBar1.Value = 52